HTTP ACCESS

Voila comment changer le port d’ecoute de base de votre équipement. Cela permet également de limiter l’accès via une ACL et s’authentifier en local par exemple.

ip http server
ip http port 8080
ip http access-class 10
ip http authentication local
#sh ip access 10
Standard IP access list 10
    10 permit 10.255.100.0, wildcard bits 0.0.0.255 (16 matches)

Spanning-Tree

Astuce pour changer les ports BLK.

Lorsque l’on veut changer le port BLK depuis le switch distant, changer la priorité du port : port-priority. Pour changer en local utiliser la commande cost.

IRDP – ICMP Router Discovery Routing Protocol

IRDP est un protocol du type « First Hop Redundancy Protocol » comme HSRP VRRP et GLBP.

Il fonctionne toutefois légèrement différement.  IRDP envoie des paquets en multicast avec comme information une IP à utiliser comme passerrelle par défaut.  Il est possible pour des raisons de redondance que plusieurs équipements envoient un paquet IRDP.

Exemple :

Nous avons R1 et R2 en HSRP et SW1 dans le même sous réseau. Pour pousser un peu plus le test nous allons configurer R1 en server DHCP.

Le réseau utilisé est 172.16.100.0/24

R1 : 172.16.100.253 / R2 : 172.16.100.252.

Dans l’exemple nous allons configurer un Pool DHCP permettant de n’attribuer que l’adresse 172.16.100.254. Pour cela nous avons choisis d’exclure tout simplement toutes les autres adresses.

Configuration :

R1(config-if)#do sh run | sec dhcp
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.100.1 172.16.100.253
ip dhcp pool DhcpPool
network 172.16.100.0 255.255.255.0
interface FastEthernet0/0
 ip address 172.16.100.253 255.255.255.0
 ip irdp
 ip irdp multicast
 ip irdp maxadvertinterval 20
 ip irdp minadvertinterval 20
 ip irdp holdtime 60
 ip irdp preference 200
 duplex auto
 speed auto
 standby version 2
 standby 1000 ip 172.16.100.1
 standby 1000 timers msec 250 msec 750
--
R2(config-if)#do sh run int fa0/0
!
interface FastEthernet0/0
ip address 172.16.100.252 255.255.255.0
ip irdp
ip irdp multicast
ip irdp maxadvertinterval 20
ip irdp minadvertinterval 20
ip irdp holdtime 60
ip irdp preference 100
duplex auto
speed auto
standby version 2
standby 1000 ip 172.16.100.1
standby 1000 timers msec 250 msec 750
standby 1000 priority 110
standby 1000 preempt
--
SW1(config-if)#do sh run | inc ip routing|gdp
no ip routing
ip gdp irdp
SW1(config-if)#do sh run int vlan 2
!
interface Vlan2
 ip address dhcp
 ip irdp
end
Comme le montre les configurations et plus particulièrement SW1 nous n’avons pas configuré d’IP et de passerelle par défaut.
Grace au server DHCP et IRDP nous allons voir que l’on pourtant toute ces informations de configuré. Le switch est donc « reachable ».
SW1(config-if)#do sh ip int brief | exc una
Interface                  IP-Address      OK? Method Status                Protocol
Vlan2                      172.16.100.254  YES DHCP   up                    up
SW1(config-if)#do sh ip route
Gateway         Using  Interval  Priority   Interface
172.16.100.252  IRDP       21       100     Vlan2
172.16.100.253  IRDP       21       200     Vlan2
Default gateway is 172.16.100.253
Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty
Nous pouvons voir que nous recevons deux routes par défaut cependant IRDP préfère celle avec la plus grande priorité.
Debug :

SW1#sh ip irdp vlan 2
Vlan2 has router discovery enabled
Advertisements will occur between every 450 and 600 seconds.
Advertisements are sent with broadcasts.
Advertisements are valid for 1800 seconds.
Default preference will be 0.
SW1#debug ip packet
IP packet debugging is on
SW1#
*Mar  1 01:36:48.947: IP: s=172.16.100.252 (Vlan2), d=224.0.0.1, len 36, rcvd 1
*Mar  1 01:36:54.875: IP: s=172.16.100.253 (Vlan2), d=224.0.0.1, len 36, rcvd 1

SW1#debug ip routing
IP routing debugging is on
SW1#
*Mar  1 01:38:28.935: GDPclient: 172.16.100.252 via IRDP, interval 20, exp 0x5AED13, priority 100
*Mar  1 01:38:34.883: GDPclient: 172.16.100.253 via IRDP, interval 20, exp 0x5B044A, priority 200