Frame relay

De Zed-Wiki
Aller à : Navigation, rechercher

Frame Relay

Terminologie

  • Permanent Virtual Circuit PVC
  • Data Link Connection Identifier DLCI
  • Local Management Interface LMI
  • Network to Network Information NNI
  • Local Access Rate / Commited Information Rate CIR

Etat des PVC

  • ACTIVE -> Fonctionne des deux cotés
  • INACTIVE -> Fonctionne pas du coté distant
  • DELETED -> Fonctionne pas du coté local

Troubleshoot Frame Relay

sh frame-relay pvc : Cette commande est très pratique pour connaitre le DLCI a utiliser lorsque l'on est connecte sur un switch Frame Relay

sh frame-relay map : Permet de voir le mapping

sh frame-relay lmi : Permet de voir en autre la partie DCE / DTE ainsi que les compteurs.

Architecture utilisée

FR-multipoint.png

Dans cette configuration, nous avons configuré une architecture Type Hub and Spoke avec entre R2 et R3 une liaison Frame-Relay point-to-point et entre R2, R4 et R5 du multipoint.

Le reseau point-to-point entre R2 et R3 est le : 192.168.0.0/24. R2 -> .1 et R3 -> .2 Le reseau multipoint entre R2, R4 et R5 est le : 192.168.1.0/24. R2 -> .1, R4 -> .2 et R5 -> .3

Loopback R2 : 2.0.0.1/24 Loopback R3 : 3.0.0.1/24 Loopback R4 : 4.0.0.1/24 Loopback R5 : 5.0.0.1/24

Nous avons également configuré EIGRP avec l'AS 100 pour voir la redistribution des routes entre les routeurs et voir le problème du à la protection SPLIT HORIZON qui empeche de recevoir les routes de R4 et R5 mutuellement. En effet SPLIT HORIZON a pour but de ne pas renvoyer les routes sur l'interface dont ils les a recu. Pour cela il faut ajouter une commande sur le router Hub : R2 sur la sous interface correspondante : no ip split-horizon eigrp <AS>.

Cela aura pour incidence de renogocier les sessions et par conséquent un UP/DOWN de la session eigrp.

Configuration Frame Relay Point-To-Point

int se0/0
encapsulation frame-relay
no shut
int se0/0.1 point-to-point
ip addr x.x.x.x x.x.x.x
frame-relay interface-dlci <Local DLCI>

Configuration Frame Relay Multipoint

int se0/0
encapsulation frame-relay
int se0/0.1
ip addr x.x.x.x x.x.x.x
no frame-relay invers
no arp frame
frame-relay map ip <Remote Ip> <Local DLCI> broadcast

Config du LAB

Pré-requis configurer le switch FRAME-RELAY avec les bon DLCI sur les bon ports :

Sw-fr.JPG

  • Le port 1 relie le router R2 avec les DLCI 101, 102 et 103
  • Le port 10 relie le router R3 avec le DLCI 202
  • Le port 11 relie le router R4 avec le DLCI 203
  • Le port 12 relie le router R5 avec le DLCI 204

Configuration de R2

...
!
interface Loopback0
 ip address 2.0.0.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 192.168.0.1 255.255.255.0
 frame-relay interface-dlci 101
!
interface Serial0/0.3 multipoint
 ip address 192.168.1.1 255.255.255.0
 no ip split-horizon eigrp 100
 no arp frame-relay
 frame-relay map ip 192.168.1.2 102 broadcast
 frame-relay map ip 192.168.1.3 103 broadcast
 no frame-relay inverse-arp
!
router eigrp 100
 network 2.0.0.0 0.0.0.255
 network 192.168.0.0
 network 192.168.1.0
 auto-summary
!
...

Configuration de R3

...
interface Loopback0
 ip address 3.0.0.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 192.168.0.2 255.255.255.0
 frame-relay interface-dlci 202
!
router eigrp 100
 network 3.0.0.0 0.0.0.255
 network 192.168.0.0
 network 192.168.1.0
 auto-summary
...

Configuration de R4

...
interface Loopback0
 ip address 4.0.0.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.2 multipoint
 ip address 192.168.1.2 255.255.255.0
 no arp frame-relay
 frame-relay map ip 192.168.1.1 203 broadcast
 no frame-relay inverse-arp
!
router eigrp 100
 network 4.0.0.0 0.0.0.255
 network 192.168.0.0
 network 192.168.1.0
 auto-summary
...

Configuration de R5

...
interface Loopback0
 ip address 5.0.0.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 multipoint
 ip address 192.168.1.3 255.255.255.0
 no arp frame-relay
 frame-relay map ip 192.168.1.1 204 broadcast
 no frame-relay inverse-arp
!
router eigrp 100
 network 5.0.0.0 0.0.0.255
 network 192.168.1.0
 auto-summary
...

Debug FRAME RELAY

R2:

R2#sh frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 2785          output pkts 2836         in bytes 234251
  out bytes 237898         dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 2807      out bcast bytes 235794
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 03:26:48, last time pvc status changed 03:25:48

R2#sh frame-relay map
Serial0/0.3 (up): ip 192.168.1.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial0/0.3 (up): ip 192.168.1.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active
Serial0/0.1 (up): point-to-point dlci, dlci 101(0x65,0x1850), broadcast
          status defined, active
R2#sh frame-relay lmi

LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 1241             Num Status msgs Rcvd 1242
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:56         Last Full Status Rcvd 00:00:56

R3:

R3#sh frame pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 202, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 2992          output pkts 2939         in bytes 250907
  out bytes 247132         dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 2910      out bcast bytes 245108
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 03:37:39, last time pvc status changed 03:36:39
R3#sh frame map
Serial0/0.1 (up): point-to-point dlci, dlci 202(0xCA,0x30A0), broadcast
          status defined, active
R3#sh frame lmi

LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 1306             Num Status msgs Rcvd 1307
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:49         Last Full Status Rcvd 00:00:49

R4:

R4#sh frame pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 203, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.2

  input pkts 249           output pkts 193          in bytes 18476
  out bytes 12966          dropped pkts 7           in pkts dropped 7
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 150       out bcast bytes 9570
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 02:17:48, last time pvc status changed 02:17:48
R4#sh frame map
Serial0/0.2 (up): ip 192.168.1.1 dlci 203(0xCB,0x30B0), static,
              broadcast,
              CISCO, status defined, active
R4#sh frame lmi

LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 1311             Num Status msgs Rcvd 1312
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:07         Last Full Status Rcvd 00:00:07

R5:

R5#sh frame pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 204, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 147           output pkts 166          in bytes 9950
  out bytes 10470          dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 153       out bcast bytes 9582
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 02:22:36, last time pvc status changed 02:21:36
R5#sh frame map
Serial0/0.1 (up): ip 192.168.1.1 dlci 204(0xCC,0x30C0), static,
              broadcast,
              CISCO, status defined, active
R5#sh frame lmi

LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 856              Num Status msgs Rcvd 857
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:44         Last Full Status Rcvd 00:00:44

Debug eigrp

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       2.0.0.0/24 is directly connected, Loopback0
D       2.0.0.0/8 is a summary, 03:46:54, Null0
D    3.0.0.0/8 [90/2297856] via 192.168.0.2, 03:42:54, Serial0/0.1
D    4.0.0.0/8 [90/2297856] via 192.168.1.2, 02:06:00, Serial0/0.3
D    5.0.0.0/8 [90/2297856] via 192.168.1.3, 02:06:00, Serial0/0.3
C    192.168.0.0/24 is directly connected, Serial0/0.1
C    192.168.1.0/24 is directly connected, Serial0/0.3

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    2.0.0.0/8 [90/2297856] via 192.168.0.1, 03:43:12, Serial0/0.1
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       3.0.0.0/24 is directly connected, Loopback0
D       3.0.0.0/8 is a summary, 03:43:14, Null0
D    4.0.0.0/8 [90/2809856] via 192.168.0.1, 02:06:19, Serial0/0.1
D    5.0.0.0/8 [90/2809856] via 192.168.0.1, 02:06:19, Serial0/0.1
C    192.168.0.0/24 is directly connected, Serial0/0.1
D    192.168.1.0/24 [90/2681856] via 192.168.0.1, 02:30:15, Serial0/0.1

R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    2.0.0.0/8 [90/2297856] via 192.168.1.1, 02:06:26, Serial0/0.2
D    3.0.0.0/8 [90/2809856] via 192.168.1.1, 02:06:26, Serial0/0.2
     4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       4.0.0.0/24 is directly connected, Loopback0
D       4.0.0.0/8 is a summary, 02:06:26, Null0
D    5.0.0.0/8 [90/2809856] via 192.168.1.1, 02:06:26, Serial0/0.2
D    192.168.0.0/24 [90/2681856] via 192.168.1.1, 02:06:27, Serial0/0.2
C    192.168.1.0/24 is directly connected, Serial0/0.2

R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    2.0.0.0/8 [90/2297856] via 192.168.1.1, 02:06:40, Serial0/0.1
D    3.0.0.0/8 [90/2809856] via 192.168.1.1, 02:06:40, Serial0/0.1
D    4.0.0.0/8 [90/2809856] via 192.168.1.1, 02:06:40, Serial0/0.1
     5.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       5.0.0.0/24 is directly connected, Loopback0
D       5.0.0.0/8 is a summary, 02:06:40, Null0
D    192.168.0.0/24 [90/2681856] via 192.168.1.1, 02:06:40, Serial0/0.1
C    192.168.1.0/24 is directly connected, Serial0/0.1